In serious need of Unity help on OSX

Moderator: JohnMeyer

Posts: 15
Joined: Wed Dec 06, 2017 5:46 pm

In serious need of Unity help on OSX

Postby LuckyMcD » Fri Jan 12, 2018 12:46 pm

I'm having major issues with Unity on OSX. I accidentally downloaded the wrong version initially. I tried installing Course Forge, but got error messages. I then noticed my mistake so I tried a complete uninstall and reinstall.

When I did the uninstall I deleted:
~/New Unity Project
~/Library/Application Support/Default Company
/Library/Application Support/Unity

I then downloaded the right version and tried to run it. I think I may have missed some deeply hidden files that need to be uninstalled from the previous incorrect install because when I try to run 5.2.3f1 I get error messages and it seems to think the assets were already installed, so it didn't reinstall them.

When I run the freshly installed 5.2.3f1 it asks me to sign in. I'm able to do that with no problem, and then it checks for a license. Not finding one, I select personal edition, agree to the requirements, it is activated, and I try to start using it. I am able to start a new project, but when it starts compiling I get an error message. It says:

Copying File Failed
Copying ~/Library/Preferences/Unity/Editor-5.x/Layouts/Default.wlt to Library/CurrentLayout.dwlt: No such file or directory

I can try again, but no matter how many times I try it doesn't work. The other chances are cancel or force quit. I've tried both in my series of uninstalls and reinstalls, and they seem to have the same result. It will continue trying to open before sending another error message. It reads:

Failed to Load Window Layout
This can happen if layout contains custom windows and there are compile errors in the project.

At this point I can Load Default Layout, Revert Factory Settings, or Quit. Again they all seem to have the same result. I am eventually taken into the Unity app, but there is virtually nothing loaded. I can't change the layout, because there are not alternate options. There is nothing listed in the assets folder. When I go to import a package, the only option available is custom package (I remember there being many more initially). Attempting to install Course Forge I can go to import package, then custom package, and I can select the Course Forge Tutorial. However when I do so I getting an error saying:

Nothing to Import!
All assets from this package are already in your project.

At this point I am unable to do just about anything in Unity. I've tried several uninstalls and reinstalls. I tried repairing permissions. I've restarted multiple times. I've tried patches and eventually tried other versions just to see if I could fix it. Any older versions will partially load Course Forge, but then crash. Any newer versions say I am attempting to use obsolete packages and run an API Updater. Curiously I can run older or new versions of Unity, just can't install Course Forge in them. I know the Course Forge Tutorial only works in 5.2.3f1, but I can't do anything in that version until whatever the problem is fixed. Any assistance would be greatly appreciated as I've been working at this for 2 days and have made no progress at all.

User avatar
Posts: 5130
Joined: Thu Mar 05, 2015 4:02 pm
Location: Chicago

Re: In serious need of Unity help on OSX

Postby Zmax » Fri Jan 12, 2018 1:03 pm

Might try asking this in Perfect Parallel CF forum.
Site Admin

JNPG Simulator Winter Tour 18 (sim): ... l?id=10036

OGT Simulator Tour Facebook:

Posts: 15
Joined: Wed Dec 06, 2017 5:46 pm

Re: In serious need of Unity help on OSX

Postby LuckyMcD » Fri Jan 12, 2018 1:17 pm

Thanks for the suggestion. I'll get right on that. I wasn't sure the best place to post it.

Posts: 15
Joined: Wed Dec 06, 2017 5:46 pm

Re: In serious need of Unity help on OSX

Postby LuckyMcD » Thu Jan 18, 2018 4:24 pm

I figured out the problem and have solved it. I figured I would post a follow up for anyone who has the same problem. I am not only running Mac OSX, but specifically High Sierra. An updated file system also came with the updated operating system. Unity has problems with the new file system. Updated versions have been patched to fix this problem, but Unity has ended support for versions 5.4 or older. Therefore 5.2.3, the version needed for the current Course Forge, doesn't run on OSX High Sierra. If you have already installed High Sierra you have two choices. You can revert to an old OS or run Unity off a drive that hasn't been formatted with the new file system. I always keep the hard drives from my old computers, so I had a few old ones. I deleted all Unity files off my current hard drive (the one recently formatted for High Sierra) and installed 5.2.3 on one of the old hard drives. I fired it up and sure enough it worked. I then was able to install Course Forge and everything runs smoothly. It is kind of a pain to have to hook up my old hard drive and run off of it, but I was happy to finally have Course Forge and wanted to help out anybody who has similar issues.

Posts: 4
Joined: Sat Dec 30, 2017 3:46 pm

Re: In serious need of Unity help on OSX

Postby marauders1 » Sun Jan 21, 2018 2:25 am

Thanks for posting. I upgraded to High Sierra last night and experienced all of the issues you described. I'm about half done with my first course, so I was feeling a mix of disbelief and despair that all that work might be for nothing.

I hooked up an external hard drive formatted HFS+ (Mac OS Extended), reinstalled Unity 5.2.3 on the drive, reimported my project and everything is good.

What a relief! Thanks again.

Return to “Course Forge Discussions & Videos”

Who is online

Users browsing this forum: No registered users and 8 guests